Chapter 3: Tutorial - How To...
Chapter 3: Tutorial

Now that you've gotten a basic understanding of the features and functions of TypeStyler, it's time to try out all those wonderful new concepts. This tutorial is a free-form exploration of TypeStyler's unique capabilities. Within the context of creating a set of travel designs, we'll engage in a little playful invention, taking advantage of TypeStyler's ease of use and flexibility to let the creative juices flow. When you finish this tutorial you'll have had some practice combining TypeStyler's various features.

The techniques presented in this tutorial are fully described elsewhere in this User's Guide. It is assumed that you are familiar with the basic use of the Macintosh and have installed the TypeStyler program and its Libraries into a single folder on your hard disk. For complete installation instructions, please refer to “Chapter 1: Startup and Introduction.”

In this tutorial, we assume that the colors are set to Millions and the Screen Resolution is set to 1024 X 768. These are set in the Apple menu's Control Panels, in Monitors and Sound. If you do not have millions of colors available, then choose thousands of colors.

As you go through the tutorial don't be too concerned with perfecting the style at this point, you can change it at any time. Feel free to experiment; the possibilities are almost endless.

Start TypeStyler by double-clicking its icon. (Double-click the application name if your disk contents are not listed by icon.)

If you have not personalized your copy of the program, a dialog box will appear asking you to do so at this time.
When TypeStyler opens a new document, it defaults to a 100% view. In this tutorial we are going to create a simple logo.

We are now going to create a text object.
• Select the text tool, and drag out a rectangle approximately two inches high by six inches wide. This will be the size of your text object. When the mouse button is released, the Text Attributes dialog will automatically appear.

You can create a text object with a particular point size by clicking the text tool cursor on the page (not click-dragging a box), and choosing a specific size in the Text Attributes dialog. The default click size is 72 points.
You choose and select a text object’s attributes from this dialog (shape, style, font, characters, etc.). On the left side of the dialog is the Shape Library which you use to apply shapes to your text. On the right side is the Style Library which you use to apply styles to your text. In the middle is a pop-up menu that allows you to choose a particular typeface for your text object. The Style Workshop... button takes you to the Style Workshop where you can create a custom style. A blinking cursor indicates where to type in your text.

- Type the word “California”. We’ll use this word as part of our design.
TypeStyler uses Charcoal as its default font; let’s use a different font.

- Select Incised901 Ct BT from the font pop-up menu in the center of the Text Attributes dialog. The word California will change from Charcoal to Incised901 Ct BT in the text entry area and in the Style Library.

- Click the OK button in the Text Attributes dialog. When you click OK, your text object appears selected in the Main window. It will appear with the message you typed in (California), displayed in the typeface you specified (Incised901 Ct BT), in the shape (Straight) and style (Black) that appear in the respective libraries, set to the size originally specified in the Main window (2” x 6”).

You may also adjust the spacing between individual pairs of letters if you find that two specific letters end up too close together or too far apart. This pair of letters is known as a kerning pair and can be adjusted in the Kerning Pair dialog.

- Open the Text Attributes dialog (if it isn’t already open) by double-clicking the text object with the Pointer tool. Then, highlight the first two letters of the word ‘California’ in the text entry area. The Kerning Pair... button should be activated. It is activated by the selection of two (only two) adjacent characters in the text entry area.
Chapter 3: TypeStyler Tutorial

• Click the Kerning Pair... button. This will bring up the Kerning Pair dialog with the particular letter pair that you have highlighted in the text entry area.

Click-dragging (click and hold down the mouse button and dragging the mouse) on either of the letters in this box will allow you to manually control the amount of space between them. You can also click on the arrows to set the spacing numerically. Experiment to find a value that looks good.
• For now, click the Cancel button and return to the Main window. This kerning pair should not need adjustment.

This is a good time to experiment with the text object's style. You can customize the style of an object in the Style Workshop.

• Bring up the Style Workshop dialog by selecting the object and choosing Style Workshop... from the Options menu (command-E). Or double-click the text object, then click the Style Workshop... button in the Text Attributes dialog.

Figure 3.9  Style Workshop

This dialog gives TypeStyler its name. From here you can create literally millions of sophisticated fill and shadow effects to be applied to objects created with TypeStyler.

The Style Workshop allows you to fill letters with different pictures or patterns, control the thickness of their inlines and outlines, and add unique shadowing techniques unavailable elsewhere. You can also control the foreground and background color of each element of a style, and adjust its transparency amount. You can also add bump maps and gloss effects, as well as emboss and chisel the object's edges.

Let's experiment with some of the options available in this dialog.

• Click on the display box next to the word “Fill” and hold the mouse button down. A palette appears with a solid black fill selected. As you move the cursor over the Fill palette, different choices are highlighted.
Stop on the grey stone pattern that is in the first column from the left and four rows down from the top. Release the mouse button. The pattern palette disappears and the letter is now filled with that picture.

Next, let’s put a black outline around the text.

Click on the display box next to the word “Outline” and hold the mouse button down. As before, a palette of fill choices appears.
• Select the solid black fill and release the mouse button. A solid black outline is now added to the style.

We can also add a shadow to our style.

• Click on the Object/Shadow selection box in the upper left of the dialog. The word “Object” is replaced by another that says “Shadow”.

This indicates that you are now working with the shadow of this particular style. The shadow is currently invisible, since its fill, inline and outline are all set to “None” and the Shadow on/off checkbox is not checked. Let’s add a solid block shadow to our style.

• Click on the display box next to the word “Fill” and hold the mouse button down to see the Fill palette. Highlight the black square and release the mouse button.
A simple black drop shadow appears in the preview window of the Style Workshop. The default Fill Softness is set at 25% to automatically create a soft shadow. You can control the placement (direction and depth) of this shadow by moving the cursor over the character in the Preview window. The cursor changes to a shadowed hand indicating that you can click-drag the drop shadow to control its position.

Figure 3.14  Shadow fill with soft shadow effect

Figure 3.14  Moving the shadow
• Click the Cast shadow radio button below the menu that says "Basic Shadow". The drop shadow will change position to now be cast in front of the object.

![Figure 3.16  Cast shadow effects](image)

![Figure 3.17  Adjust shadow using the Lighting trackball](image)
• Change the direction of the trackball to position the shadow behind the object. The trackball is controlled by click-dragging within the trackball. Use the sliders to adjust the light distance and tilt of the shadow. The flip contour checkbox can also be checked. This can sometimes add a pleasing effect to the shadow style (especially if the object has been shaped).

• For our tutorial chose the Drop shadow radio button and then click OK to return to the Main window to see the newly customized style applied to the existing text object.

Figure 3.18 Final style applied to text object in Main window

• Now let’s choose a Style from the Style menu. California is the Golden State, so let’s choose the Gold style. Your text should now repaint in gold.

• The Gold fill adds width to the characters. These would look better if the letters were spaced a little farther apart. With your object still selected choose “Type Options” from the Type menu. Grab the “ABC” control of the Letters Spacing control and spread the spacing a bit (to about .16 ems) and click OK.
• From the Special menu choose the Color Letter Series. You'll see that this is added to your current style. You can go to the Fill Series editor, change an image or number of colors in the array etc. and click OK to return to the Main window.

Figure 3.19 Type Options dialog

• We want our text object to be all upper case letters. We could go into the Text Attribute dialog or we can simply choose All Caps from the Special menu.

Figure 3.20 Fill Series Editor
TypeStyler excels in typographic flexibility. However, all the sophisticated styling and shaping capabilities of TypeStyler can be applied to graphic objects as well.

Graphic objects in TypeStyler are called panels. TypeStyler offers six basic geometric shapes as panels, two of which are adjustable. These shapes can be manipulated and styled just as text can. Panels use the same Shape Library, Style Library, and Style Workshop as text objects and are treated in much the same way within TypeStyler.

We are now going to add a panel object to use behind the existing text object in the Main window.

Figure 3.21  Dragging a panel box

- Select the panel tool and click-drag a small rectangle below the text object. When the mouse button is released the Panel Attributes dialog will automatically open.

In this dialog you can create a wide variety of panels to be used as design elements and/or backdrops for your text objects. In the center of the dialog is the Shape palette. Use this to select a basic, starting shape. When selected, the polygon and star shapes have slider controls. These controls allow you to select a custom number of sides, etc., to create new shapes.
On the left side of the dialog is the Shape Library which you use to apply shapes (distortions) to your panel. On the right side is the Style Library which you use to apply styles to your panel. The Style Workshop... button takes you to the Style Workshop where you can create a custom style for your panel.

- Select the rounded rectangle from the Shape palette (the second upper left shape). Leave Shape #1 selected in the Shape Library. Using the right scroll arrow, select the thirteenth style (Black w/ Soft Shadow) from the Style Library.
• Click OK. When you click OK, the basic Panel Shape Rounder Rectangle in displayed in the Main window in the shape (Straight) and the style (Black w/ Soft Shadow) specified in the Panel Attributes dialog, set to the size originally defined in the Main window with the Panel tool.

We’ll now style the panel by selecting it and then choosing the Style button from the Tool palette. This brings you into the Style Workshop. Panels can be styled just like text objects can.

• Click on the black foreground box under Fill Colors. This brings up the color palette. Choose a light green from the palette.

![Color Palette](image)

Figure 3.24  Color Palette

• We’ll now add some texture to our panel by applying Noise. The Noise effect creates a random graininess or overall speckled appearance. Clicking on Noise brings up a slider, choose 50%. Then click OK to return to the Main window.

• Select the Text tool from the Tool palette and position the cursor on your panel object and grow a text box approximately a half an inch high by seven inches long.

• Now in the text entry area type “Discover the Golden State”, and click on OK to return to the Main window. Save your work by choosing Save from the file menu.
Because TypeStyler documents are always editable you can use TypeStyler documents as template for future projects.

- We'll use the California graphic as the basis for another logo.

- Double click on the "California" text object to enter the Text Attributes dialog. Highlight California and then type Colorado. From the Shape Library pop-up scroll and select Banner Arched Top. From the Style Library pop-up scroll and select Eclipse. From the Type menu pop-up select Aachen Medium LET. Click on OK to return to the Main window.

- Using the Pointer tool select the panel object. From the Shape menu scroll and select Banner Arched Top.

- Now double click on the "Discover the Golden State" message to enter the Text Attributes dialog. Change the text to read "Discover the Rockies". Click on OK to return to the Main window.

We're now going to use the Shaper tool to fine tune the message and the panel to compete the design.

You can use the Shaper tool to make changes to either the shape or size of the text or panel objects. Remember that pressing the Command key will temporarily change the Shaper tool into the Pointer tool if you need
• Using the Pointer tool select the panel. Now select the Shaper tool from the tool palette. Notice that the 'handles' on the panel disappear and Shaper lines appear on the top and bottom of the panel. To better see this choose Quick View (Command-Y) from the View menu or

Figure 3.26 Logo design before shaping to move the Panel object.

Figure 3.27 Logo design before shaping in Quick View mode
click on the gray paint brush in the tool palette (Quick View bottom).

- Select the top center control point of the panel and drag it up to match the contour or shape of "Colorado".

- Now using the Pointer tool select the message and scroll and select Banner Arched Top from the Shape menu. With the message still selected choose the Shaper tool again. Use the control points of the object to fit within the panel.

- Select Styled Preview (Command-Y) from the View menu to see the Styled logo design. Use the Pointer tool to reposition the objects as necessary to achieve the desired look. You may want to print, save or export your logo before continuing.
Chapter 3: TypeStyler Tutorial

Now, using what you have learned in this tutorial let’s lay out a design for Florida.

• Choose New from the File menu.

• Select the Panel tool and grow a box about 5 inches square. In the Panel Attributes dialog, pick the shape in the top row, farthest right. (The corner size can remain set to 16.) Choose “Gold Inlined w/ Shadow” from the Style menu. Click the OK button to return to the Main page.

• Now, select the Text tool and grow a box about 3 1/2 inches square in the upper part of the Panel shape. This will bring you into the Text Attributes dialog. Type “FLA” and hit the return key, and then type “USA” on the next line.

• In the lower left corner of the Text Attributes dialog, you’ll find the “Type Options” button. Click this to go to the Type Options dialog. We want to bring the two lines of text closer together, so decrease the Line Spacing to about –13 ems and click OK.

• Back in the Text Attributes dialog again, pick a bold font such as DomBold BT and click the OK button to return to the Main page.
• With the “FLA USA” object active, pick “Color Letter Series” from the Special menu.

• Now let’s create another line of text below FLA USA. Click the Text tool again and grow a box about 1/4 inch high and 4 1/2 inches long. This brings you into the Text Attributes dialog. Type the words “DISCOVER THE MAGIC”. We want to set this text to a specific point size. To do so, click the Point Size radio button and choose 36 point size. Click the OK button to return to the Main page.

• With “DISCOVER THE MAGIC” active, choose “Color Word Series” from the Special menu. Now choose “Word Cycle” from the Web menu.

Figure 3.30 Final design in TypeStyler

• Select the FLA USA object and choose “Letter Cycle” from the Web menu.

• Now, choose a browser from “Preview in Browser” (either from the Web menu or from the File menu) and watch your graphic animate on a web page.
This section has given you a feel for some of the styling capabilities available within TypeStyler.

This completes the tutorial. You may want to print or save your logo before you quit TypeStyler. You may also want to go back and practice some of the TypeStyler skills you’ve learned. As you become more familiar with TypeStyler’s keyboard commands and features you’ll find that working with TypeStyler becomes an intuitive process and an integral part of your creative environment.